HACKINTOSH MONTRÉAL & FRANCE


Vous êtes invités a lire la charte du Forum  ICI avant de poster! La Charte du Forum


Problème Sapphire Radeon R9 270 Dual-X OC

Voir le sujet précédent Voir le sujet suivant Aller en bas

Problème Sapphire Radeon R9 270 Dual-X OC

Message par lommax le Mar 29 Juil - 17:12

Bonjour,
je viens d'installer OS X Mavericks sur ma seconde config et je rencontre des problèmes avec ma carte vidéo.
Elle n'est pas reconnue par mon Hack même après l'installation des Kexts nécessaires.
J'ai alors vu qu'il fallait injecter des DSDT's mais je ne comprend vraiment pas comment faire.
J'ai trouvé les Kext ici : [Vous devez être inscrit et connecté pour voir ce lien]
Les DSDT sont dedans.
Comme la R9 270 et la HD 7850 sont les mêmes carte graphique, je dois injecter le DSDT pour 7850, mais je ne comprends pas trop comment faire.
J'ai aussi trouvé ça : [Vous devez être inscrit et connecté pour voir ce lien]
Je ne suis pas réellement à l'aise avec autant de terme technique, alors en anglais c'est encore pire...

Merci d'avance pour l'aide que vous m'apporterez.


Dernière édition par lommax le Mar 29 Juil - 19:01, édité 2 fois

lommax
Top usr
Top usr

Messages : 77
Date d'inscription : 21/07/2014
Localisation : Sud de la Picardie

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème Sapphire Radeon R9 270 Dual-X OC

Message par chris1111 le Mar 29 Juil - 18:52

Le DSDT c'est pour la carte mere pas la carte Graphics ! O ui surement que ce dsdt est patcher pour cette carte graphics mais le dsdt est pour la config du gars en question

chris1111
Admin
Admin

Messages : 18217
Date d'inscription : 18/12/2012
Localisation : Montreal (Quebec)

Voir le profil de l'utilisateur http://www.hackintosh-montreal.com

Revenir en haut Aller en bas

Re: Problème Sapphire Radeon R9 270 Dual-X OC

Message par lommax le Mar 29 Juil - 19:02

J'ai suivi les instruction du deuxième lien (en fin de compte c'était pas bien compliqué)
Quand j'ai été voir dans le info.plist des deux Kext, l'ID de ma carte graphique y était déjà, alors j'ai été dans les Options de Clover (qui lui reconnait bien ma carte graphique d'ailleurs...), j'ai changé le FakeID avec celui de ma CG, activé InjectATI et LoadVideoBios, mais après avoir fait ces modifications, mon Hack ne boot plus, voilà ce qu'il me dit :

J'ai essayé avec seulement le FakeID changé, le Hack boot mais toujours pas de prise en charge de la carte graphique.
J'ai aussi essayé avec juste InjectATI et LoadVideoBios activé mais c'est pareille, le Hack ne Boot pas et reste sur les mêmes ligne que la photo plus haut.

Je vais donc supprimer les Kexts en question, modifier ceux d'origine, réparer les permissions et voir ce que ça donne, si ça donne rien je tenterais encore quelques petits truc dans les paramètres Clover.

Ce qui m'énerve c'est que la personne possédant la R9 270 sur InsanelyMac arrive à faire fonctionner sa CG et pas moi, alors que je suis le tuto...

Edit : l'ID de ma carte graphique est déjà dans les Kexts d'origine, j'ai quand même réinstallé le tout, réparé les permissions et reconstruit le cache, j'attends le reboot pour voir si ça fonctionne.
Si j'ai autant de problème c'est peut être aussi parce que mon Hack est reconnu comme un iMac et non Mac Pro, comment je fais le changement dans le panneau de config Clover ?

lommax
Top usr
Top usr

Messages : 77
Date d'inscription : 21/07/2014
Localisation : Sud de la Picardie

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème Sapphire Radeon R9 270 Dual-X OC

Message par chris1111 le Mar 29 Juil - 19:36

est ce que les kext étais bien la bonne version de mavericks ??

pour le smbios utilise clover configurateur

chris1111
Admin
Admin

Messages : 18217
Date d'inscription : 18/12/2012
Localisation : Montreal (Quebec)

Voir le profil de l'utilisateur http://www.hackintosh-montreal.com

Revenir en haut Aller en bas

Re: Problème Sapphire Radeon R9 270 Dual-X OC

Message par lommax le Mar 29 Juil - 19:45

Oui les Kexts étaient bien pour Mavericks, après je me suis peut être trompé, mais je doute très fort.

Et pour le SMBIOS, je sais que je dois utiliser Clover Configurator, mais comment est-ce que je dois définir tout les numéro de série etc ?

Edit : j'ai trouvé comment faire, il fallait simplement cliquer sur la petite baguette magique.
Je me retrouve donc avec un config.plist, ou est-ce que je dois le mettre ? Est-ce que se serait dans : Racine du DD -> EFI -> CLOVER ?

lommax
Top usr
Top usr

Messages : 77
Date d'inscription : 21/07/2014
Localisation : Sud de la Picardie

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème Sapphire Radeon R9 270 Dual-X OC

Message par chris1111 le Mar 29 Juil - 20:16

Mavericks a plusieurs versions

oui efi clover

chris1111
Admin
Admin

Messages : 18217
Date d'inscription : 18/12/2012
Localisation : Montreal (Quebec)

Voir le profil de l'utilisateur http://www.hackintosh-montreal.com

Revenir en haut Aller en bas

Re: Problème Sapphire Radeon R9 270 Dual-X OC

Message par lommax le Mar 29 Juil - 20:20

Il y avait bien écrit Mavericks 10.9.x, ce qui veut dire toute versions de Mavericks, donc je ne me suis pas trompé.

Je désespère de réussir à faire de cette machine un Hack, je crois que je vais abandonner l'idée...
Il me reste juste le SMBIOS comme option.

lommax
Top usr
Top usr

Messages : 77
Date d'inscription : 21/07/2014
Localisation : Sud de la Picardie

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème Sapphire Radeon R9 270 Dual-X OC

Message par chris1111 le Mar 29 Juil - 20:26

essai le  ton smbios on veras  
mais  les kext Graphics change souvent dune vession a l'autre

si tu a vut ton id dans les kext pourquoi ne pas avoir patcher tes kext de ton mavericks ??

chris1111
Admin
Admin

Messages : 18217
Date d'inscription : 18/12/2012
Localisation : Montreal (Quebec)

Voir le profil de l'utilisateur http://www.hackintosh-montreal.com

Revenir en haut Aller en bas

Re: Problème Sapphire Radeon R9 270 Dual-X OC

Message par lommax le Mar 29 Juil - 20:31

Qu’entend tu par Patcher mes Kexts ? Pour moi j'ai vu que l'ID de ma CG était dedans donc je n'avais rien à faire de plus.
Ca ne fonctionne pas mieux avec le SMBIOS de Mac Pro 3.1

Edit : Les Kexts testé sont pour Mavericks 10.9.2 ou antérieur. A moins de downgrader vers la 10.9.2, aucun moyen pour moi d'avoir ma carte graphique fonctionnel...

@chris1111 : l'installer v10 n'est plus dans les téléchargements, est-ce que tu pourrais me le passer ? Au moins lui il installe la 10.9.2, comme ça je pourrais avoir ma CG fonctionnel, il me suffira simplement de ne pas faire les mise à jour.
Merci d'avance.

lommax
Top usr
Top usr

Messages : 77
Date d'inscription : 21/07/2014
Localisation : Sud de la Picardie

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème Sapphire Radeon R9 270 Dual-X OC

Message par AXIS22 le Mar 16 Déc - 23:09

Personne pour répondre ???

AXIS22

Messages : 25
Date d'inscription : 24/08/2014
Age : 26
Localisation : Nancy

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème Sapphire Radeon R9 270 Dual-X OC

Message par Contenu sponsorisé Aujourd'hui à 20:56


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum