HACKINTOSH MONTRÉAL & FRANCE

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Capt1051
Vous devez lire la charte et vous présenter avant de poster!
➤  La Charte du Forum

➤  Présentation

Rejoignez le forum, c’est rapide et facile

HACKINTOSH MONTRÉAL & FRANCE

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Capt1051
Vous devez lire la charte et vous présenter avant de poster!
➤  La Charte du Forum

➤  Présentation
HACKINTOSH MONTRÉAL & FRANCE
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.
Le Deal du moment : -11%
PC Portable – HP Pavilion Gaming – ...
Voir le deal
824 €

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

3 participants

Page 1 sur 2 1, 2  Suivant

Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par JMB Mar 5 Mai - 12:01

J'ai essayé le voodooHDA en mode UEFI ou classique mais ça ne marche pas.


Dernière édition par JMB le Mer 6 Mai - 18:19, édité 1 fois
JMB
JMB
Super usr
Super usr

Date d'inscription : 27/05/2015
Age : 56

http://latavernedupangolin.eu

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par chris1111 Mar 5 Mai - 12:30

Tu essai trop de chose demande avant car la tu a probablement Deux kext VoodooHDA et un HDADisabler dans /S/L/E  pour rien

Quest ce que tu a essayer avant le VoodooHDA

_________________
Si notre forum t'a aidé. S'il te plaît, pense à faire un don pour nous soutenir financièrement. Merci !

Faite des Tutos d'installation après avoir réussi votre Hackintosh

La charte
chris1111
chris1111
Admin
Admin

Date d'inscription : 18/12/2012
Localisation : Laval. Québec Canada

https://www.hackintosh-montreal.com

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par JMB Mar 5 Mai - 13:58

J'ai fait la post install avec AppleAlc.kext
JMB
JMB
Super usr
Super usr

Date d'inscription : 27/05/2015
Age : 56

http://latavernedupangolin.eu

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par JMB Mar 5 Mai - 16:24

J'ai aussi viré toutes les install, du moins effacées.
JMB
JMB
Super usr
Super usr

Date d'inscription : 27/05/2015
Age : 56

http://latavernedupangolin.eu

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par emax31 Mar 5 Mai - 17:03

Tu sais qu'avec  Applealc il faut également renseigner
Devices --> Audio --> Inject (et mettre un chiffre)
Pour ce chiffre essaye : 1, 2, 3, 5, 7 reboot à chaque fois bien sur

_________________
 Thèmes  :

Icnspack-Builder & source thème by chris1111
[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Flavou14
[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) 26191810
[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) 28143910
[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) 28113810



Important : Une fois résolu, l'auteur du sujet peut ajouter [Résolu] au début du titre en cliquant sur Editer de son premier message, et ajouter un bref récapitulatif de la solution à la fin de celui-ci ou mieux faire un tuto. Merci.
emax31
emax31
Gourou
Gourou

Date d'inscription : 04/12/2013
Localisation : Ariège - Grenoble - France

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par JMB Mer 6 Mai - 5:30

@emax31 a écrit:Tu sais qu'avec  Applealc il faut également renseigner
Devices --> Audio --> Inject (et mettre un chiffre)
Pour ce chiffre essaye : 1, 2, 3, 5, 7 reboot à chaque fois bien sur

J'ai essayé les ids 1, 2, 3, 5, 7, 11, 13, 15, 16, 21, 27, 28, 29, 34 trouvées ici https://github.com/acidanthera/AppleALC/wiki/Supported-codecs

Mais ça ne fonctionne toujours pas...
JMB
JMB
Super usr
Super usr

Date d'inscription : 27/05/2015
Age : 56

http://latavernedupangolin.eu

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par chris1111 Mer 6 Mai - 5:35

@JMB a écrit:
@emax31 a écrit:Tu sais qu'avec  Applealc il faut également renseigner
Devices --> Audio --> Inject (et mettre un chiffre)
Pour ce chiffre essaye : 1, 2, 3, 5, 7 reboot à chaque fois bien sur

J'ai essayé les ids 1, 2, 3, 5, 7, 11, 13, 15, 16, 21, 27, 28, 29, 34 trouvées ici https://github.com/acidanthera/AppleALC/wiki/Supported-codecs

Mais ça ne fonctionne toujours pas...

Si ta installer VoodooHDA Legacy il ta retirer ton AppleHDA et mie en backup sur le bureau
Apple ALC ne fonctionne pas sans AppleHDA natif

Utilise Kext-Droplet pour reinstaller ton kext dans /S/L/E

Il faut aussi supprimer de Clover VoodooHDA et supprimer de /S/L/E VoodooHDA.kext et HDADisabler.kext

_________________
Si notre forum t'a aidé. S'il te plaît, pense à faire un don pour nous soutenir financièrement. Merci !

Faite des Tutos d'installation après avoir réussi votre Hackintosh

La charte
chris1111
chris1111
Admin
Admin

Date d'inscription : 18/12/2012
Localisation : Laval. Québec Canada

https://www.hackintosh-montreal.com

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par JMB Mer 6 Mai - 6:06

@chris1111 a écrit:
@JMB a écrit:
@emax31 a écrit:Tu sais qu'avec  Applealc il faut également renseigner
Devices --> Audio --> Inject (et mettre un chiffre)
Pour ce chiffre essaye : 1, 2, 3, 5, 7 reboot à chaque fois bien sur

J'ai essayé les ids 1, 2, 3, 5, 7, 11, 13, 15, 16, 21, 27, 28, 29, 34 trouvées ici https://github.com/acidanthera/AppleALC/wiki/Supported-codecs

Mais ça ne fonctionne toujours pas...

Si ta installer VoodooHDA Legacy il ta retirer ton AppleHDA et mie en backup sur le bureau
Apple ALC ne fonctionne pas sans AppleHDA natif

Utilise Kext-Droplet pour reinstaller ton kext dans /S/L/E

Il faut aussi supprimer de Clover VoodooHDA et supprimer de /S/L/E VoodooHDA.kext et HDADisabler.kext

J'ai tout viré. J'ai réinstallé appleHDA dans S/L/E avec le kext droplet

J'ai trouvé ça dans le appleALC

Code:

<dict>
               <key>AFGLowPowerState</key>
               <data>
               AwAAAA==
               </data>
               <key>CodecID</key>
               <integer>283906592</integer>
               <key>CodecName</key>
               <string>MacPeet- ALC1220 for Z390 Aorus Ultra - Output SP/HP Manualmode </string>
               <key>ConfigData</key>
               <data>
               AUccEAFHHUABRx4RAUcfkAFHDAIBVxwgAVcd
               EAFXHgEBVx8BAWccMAFnHWABZx4BAWcfAQF3
               HPABdx0AAXceAAF3H0ABhxxAAYcdkAGHHqAB
               hx+QAZccYAGXHZABlx6BAZcfAgGnHFABpx0w
               AacegQGnHwEBtxxwAbcdQAG3HiEBtx8CAbcM
               AgHnHJAB5x1hAeceSwHnHwE=
               </data>
               <key>FuncGroup</key>
               <integer>1</integer>
               <key>LayoutID</key>
               <integer>28</integer>
               <key>WakeConfigData</key>
               <data>
               AUcMAg==
               </data>
               <key>WakeVerbReinit</key>
               <true/>
            </dict>
            <dict>
               <key>AFGLowPowerState</key>
               <data>
               AwAAAA==
               </data>
               <key>CodecID</key>
               <integer>283906592</integer>
               <key>CodecName</key>
               <string>MacPeet- ALC1220 for Z390 Aorus Ultra - Output SP/HP SwitchMode</string>
               <key>ConfigData</key>
               <data>
               AUccEAFHHUABRx4RAUcfkAFHDAIBVxwgAVcd
               EAFXHgEBVx8BAWccMAFnHWABZx4BAWcfAQF3
               HPABdx0AAXceAAF3H0ABhxxAAYcdkAGHHqAB
               hx+QAZccYAGXHZABlx6BAZcfAgGnHFABpx0w
               AacegQGnHwEBtxxwAbcdQAG3HiEBtx8CAbcM
               AgHnHJAB5x1hAeceSwHnHwE=
               </data>
               <key>FuncGroup</key>
               <integer>1</integer>
               <key>LayoutID</key>
               <integer>29</integer>
               <key>WakeConfigData</key>
               <data>
               AUcMAg==
               </data>
               <key>WakeVerbReinit</key>
               <true/>
            </dict>

Vu que c'est ma CM (Z390 aorus ultra), j'en déduis que ce sont les IDs 28 et 29 qui sont les bonnes ? J'ai essayé les deux mais ça veut toujours pas...
JMB
JMB
Super usr
Super usr

Date d'inscription : 27/05/2015
Age : 56

http://latavernedupangolin.eu

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par chris1111 Mer 6 Mai - 6:37

essai celui la
Fichiers joints
[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Attachment
AppleALC.kext.zip Vous n'avez pas la permission de télécharger les fichiers joints.(881 Ko) Téléchargé 3 fois

_________________
Si notre forum t'a aidé. S'il te plaît, pense à faire un don pour nous soutenir financièrement. Merci !

Faite des Tutos d'installation après avoir réussi votre Hackintosh

La charte
chris1111
chris1111
Admin
Admin

Date d'inscription : 18/12/2012
Localisation : Laval. Québec Canada

https://www.hackintosh-montreal.com

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par JMB Mer 6 Mai - 7:25

Il faut activer Reset HDA et AFGlowPowerState ?
JMB
JMB
Super usr
Super usr

Date d'inscription : 27/05/2015
Age : 56

http://latavernedupangolin.eu

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par chris1111 Mer 6 Mai - 8:13

essai

_________________
Si notre forum t'a aidé. S'il te plaît, pense à faire un don pour nous soutenir financièrement. Merci !

Faite des Tutos d'installation après avoir réussi votre Hackintosh

La charte
chris1111
chris1111
Admin
Admin

Date d'inscription : 18/12/2012
Localisation : Laval. Québec Canada

https://www.hackintosh-montreal.com

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par JMB Mer 6 Mai - 10:15

Ca ne veut toujours pas...

J'ai essayé de rajouter Rename HDAS to HDEF Find* [HEX]: 48444153 Replace [HEX]: 48444546
Toujours rien.

J'ai trouvé ça : https://github.com/acidanthera/AppleALC/blob/master/Resources/ALC1220/Platforms28.xml

J'ai aussi essayé en mettant appleALC.kext dans L/E... (je l'ai enlevé depuis), rien.

Mais je ne sais pas si ça peut servir et comment on s'en sert...
JMB
JMB
Super usr
Super usr

Date d'inscription : 27/05/2015
Age : 56

http://latavernedupangolin.eu

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par JMB Mer 6 Mai - 10:25

Eventuellement qualqu'un aurait un appleHDA d'origine au cas ou j'aurais corrompu le mien ?
JMB
JMB
Super usr
Super usr

Date d'inscription : 27/05/2015
Age : 56

http://latavernedupangolin.eu

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par chris1111 Mer 6 Mai - 10:28

voila de Cata 10.15.4
Fichiers joints
[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Attachment
AppleHDA.kext.zip Vous n'avez pas la permission de télécharger les fichiers joints.(1.5 Mo) Téléchargé 3 fois

_________________
Si notre forum t'a aidé. S'il te plaît, pense à faire un don pour nous soutenir financièrement. Merci !

Faite des Tutos d'installation après avoir réussi votre Hackintosh

La charte
chris1111
chris1111
Admin
Admin

Date d'inscription : 18/12/2012
Localisation : Laval. Québec Canada

https://www.hackintosh-montreal.com

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par JMB Mer 6 Mai - 11:25

Bon ben ça veut pas... Je pense que j'ai tout essayé avec applealc... Si je veux refaire une tentative voodoo en uefi il faut enlever applehda ?
JMB
JMB
Super usr
Super usr

Date d'inscription : 27/05/2015
Age : 56

http://latavernedupangolin.eu

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par chris1111 Mer 6 Mai - 11:38

@JMB a écrit:Bon ben ça veut pas... Je pense que j'ai tout essayé avec applealc... Si je veux refaire une tentative voodoo en uefi il faut enlever applehda ?

Non AppleALC Very Happy

_________________
Si notre forum t'a aidé. S'il te plaît, pense à faire un don pour nous soutenir financièrement. Merci !

Faite des Tutos d'installation après avoir réussi votre Hackintosh

La charte
chris1111
chris1111
Admin
Admin

Date d'inscription : 18/12/2012
Localisation : Laval. Québec Canada

https://www.hackintosh-montreal.com

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par JMB Mer 6 Mai - 11:54

Oops oui !
JMB
JMB
Super usr
Super usr

Date d'inscription : 27/05/2015
Age : 56

http://latavernedupangolin.eu

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par JMB Mer 6 Mai - 12:41

Ca ne marche toujours pas, là je sèche. Est-ce que le type d'install pourrait expliquer (j'ai utilisé macOS Catalina HD) ?

Sinon je suis preneur d'idées...
JMB
JMB
Super usr
Super usr

Date d'inscription : 27/05/2015
Age : 56

http://latavernedupangolin.eu

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par chris1111 Mer 6 Mai - 12:45

ca aucun rapport dapres moi il te faut un patch Audio aussi dans le DSDT essai de voir si cest le cas sur le meme Hackintosh ailleurs
Pour AppleALC je dit mais je comprend pas que voodooHDA marche pas??

_________________
Si notre forum t'a aidé. S'il te plaît, pense à faire un don pour nous soutenir financièrement. Merci !

Faite des Tutos d'installation après avoir réussi votre Hackintosh

La charte
chris1111
chris1111
Admin
Admin

Date d'inscription : 18/12/2012
Localisation : Laval. Québec Canada

https://www.hackintosh-montreal.com

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par chris1111 Mer 6 Mai - 12:50

jai envoyer un MP a un sur Insanelymac ont vas voir ce qu'il vas dire

_________________
Si notre forum t'a aidé. S'il te plaît, pense à faire un don pour nous soutenir financièrement. Merci !

Faite des Tutos d'installation après avoir réussi votre Hackintosh

La charte
chris1111
chris1111
Admin
Admin

Date d'inscription : 18/12/2012
Localisation : Laval. Québec Canada

https://www.hackintosh-montreal.com

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par JMB Mer 6 Mai - 12:52

@chris1111 a écrit:ca aucun rapport dapres moi il te faut un patch Audio aussi dans le DSDT essai de voir si cest le cas sur le meme Hackintosh ailleurs
Pour AppleALC je dit mais je comprend pas que voodooHDA marche pas??

Je t'avouerais que moi non plus... Ca pourrait avoir un rapport avec l'USB ? Je dis ça mais je dis peut-être une connerie... Wink PArce que parfois quand je reboot j'ai un freeze, plus de souris, plsu de clavier... Plus rien du tout peut-être... J'éteins et je relance et ça remarche.
JMB
JMB
Super usr
Super usr

Date d'inscription : 27/05/2015
Age : 56

http://latavernedupangolin.eu

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par JMB Mer 6 Mai - 12:56

@chris1111 a écrit:jai envoyer un MP a un sur Insanelymac ont vas voir ce qu'il vas dire

SUper merci. JE pense que c'ets normal mais je ne peux même pas lancer le prefpzn de voodohda, ça me dit Impossible de charger la fenêtre de préférences VoodooHDA.

Là je viens d'installer mon rack audio moto 828mkII en FW et ça marche sans pb. Donc j'ai du son mais ça ne remplace paas le son intégré pour tout ce sont des pilotes particuliers. J'ai lancer le PC sur un disque windows, le chip realtek est reconnu sans soucis donc pas de pb hardware.
JMB
JMB
Super usr
Super usr

Date d'inscription : 27/05/2015
Age : 56

http://latavernedupangolin.eu

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par JMB Mer 6 Mai - 16:31

J'ai peut être un début d’explication : il reste un voodoohda.kext dans S/L/E... Je pensais l'avoir enlevé mais il est toujours là et je ne sais pas comment l'enlever
JMB
JMB
Super usr
Super usr

Date d'inscription : 27/05/2015
Age : 56

http://latavernedupangolin.eu

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par chris1111 Mer 6 Mai - 16:47

@JMB a écrit:J'ai peut être un début d’explication : il reste un voodoohda.kext dans S/L/E... Je pensais l'avoir enlevé mais il est toujours là et je ne sais pas comment l'enlever

Bin tes testes AppleALC sont pas bon Je Tavait dit de faire ca avant ha12

Mettre le disk en R/W
https://www.hackintosh-montreal.com/t8691-disk-rw

_________________
Si notre forum t'a aidé. S'il te plaît, pense à faire un don pour nous soutenir financièrement. Merci !

Faite des Tutos d'installation après avoir réussi votre Hackintosh

La charte
chris1111
chris1111
Admin
Admin

Date d'inscription : 18/12/2012
Localisation : Laval. Québec Canada

https://www.hackintosh-montreal.com

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par JMB Mer 6 Mai - 17:01

Ca Marche !!!!

Voilà ce que j'ai fait après avoir viré voodooHDA.kext et HDADisabler.kext (j'ai vu qu'ils étaient toujours là en faisant un sudo kextstat). J'ai reconstruit le kext cache un peu à la one again, j'ai réinstallé le support wifi atheros vu que je me suis dit que l'appli de Chris devait bien reconstruire le cache... Pas super élégant mais ça a marché. On fait ce qu'on peut avec ce qu'on a... J'ai tenté un sudo kextcache -i / mais ça me disait que le IO80211Family.kext n'était pas super "standard", donc méfiance...

Ensuite je suis allé sur la page https://github.com/acidanthera/AppleALC/wiki/Installation-and-usage et ça disait qu'il ne fallait pas utiliser l'injection via clover, et mettre Inject = NO, par contre, il faut mettre en boot arguments alcid=layout, j'ai donc mis la valeur 28 (trouvée en épluchant un peu le appleALC.kext où il existe deux valeurs définies pour ma CM (Z390 aorus ultra). Et paf, ça marche !

Ouf... Very Happy


Dernière édition par JMB le Mer 6 Mai - 17:03, édité 1 fois
JMB
JMB
Super usr
Super usr

Date d'inscription : 27/05/2015
Age : 56

http://latavernedupangolin.eu

Revenir en haut Aller en bas

[Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4) Empty Re: [Résolu] Son ALC1220-VB ne fonctionne pas (10.15.4)

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 1 sur 2 1, 2  Suivant

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum