HACKINTOSH MONTRÉAL & FRANCE


[size=12] Vous devez lire la charte et vous présenter avant de poster!
  La Charte du Forum  [size=12]
[size=12]  Présentation  [size=12]

Problème démarrage OSx Mojave 10.14.18

Aller en bas

Problème démarrage OSx Mojave 10.14.18

Message par famter le Mer 22 Aoû - 17:22

Salut,

Après une installation très facilité par macOS Mojave HD de chris1111. Aucune erreur n'est survenue durant cette installation (voir en pièces jointes les logs). J'ai suivie à la lettre le tutoriel disponible sur Youtube, sans faire aucune adjonction (keytexts...).
Par contre après le lancement de Clover, le boot de masOS Mojave n'est jamais arrivé au bout. Le plantage à lieu à peu prêt à 60% du processus. Ne sachant pas comment récupérer le fichier de log, je joint une photo du plantage en mode verbose.

Je précise que je possède 3 disques:
- NVME: ArchLinux et Windows
- SSD: masOS Mojave (installé à partir de masOS Hight Sierra, précédemment installer sur un quatrième disque)
- HDD: Données

Je vous remercie de vos suggestions merci
Fichiers joints
Historique de Programme d’installation 22-Aug-2018.txt Historique de Programme d’installationVous n'avez pas la permission de télécharger les fichiers joints.(2.9 Mo) Téléchargé 0 fois
macOS Mojave HD-Output.txt macOS Mojave HD-OutputVous n'avez pas la permission de télécharger les fichiers joints.(10 Ko) Téléchargé 1 fois
DSC_0010.jpg Plantage démarrage masOS MojaveVous n'avez pas la permission de télécharger les fichiers joints.(105 Ko) Téléchargé 2 fois
famter
famter

Messages : 4
Date d'inscription : 10/08/2018

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème démarrage OSx Mojave 10.14.18

Message par chris1111 le Mer 22 Aoû - 21:13

Intel HD 630
Kexts requis et ajustement
Copier Coller FakePCIID.kext et FakePCIID_Intel_HD_Graphics.kext dans EFI / CLOVER / kexts / Other

Copier Coller Shiki.kext dans EFI / CLOVER / kexts / Other
Copier Coller Lilu.kext dans EFI / CLOVER / kexts / Other
Copier Coller IntelGraphicsFixup.kext dans EFI / CLOVER / kexts / Other

Liens RehabMan FakePCIID  https://bitbucket.org/RehabMan/os-x-fake-pci-id/downloads/
Liens Lilu.kext et Shiki.kext  https://github.com/acidanthera
Liens IntelGraphicsFixup.kext https://github.com/lvs1974/IntelGraphicsFixup/releases

Modification config.plist
Partition EFI /CLOVER / fichier config.plist
Ouvrir avec Clover Configurator
Boot sur la colonne de gauche ajouter: shikigva=1
Sous custom flag IntelGFX sur: 0x59168086
Sous Graphics cocher Inject Intel
ig-platform-id  0x59120000
Fait toi aussi un SMBIOS iMac 18.1
Enregistre le config.plist
chris1111
chris1111
Admin
Admin

Messages : 24973
Date d'inscription : 18/12/2012
Localisation : Laval. Québec Canada

Voir le profil de l'utilisateur http://hackintosh--montreal.forum-canada.com

Revenir en haut Aller en bas

Re: Problème démarrage OSx Mojave 10.14.18

Message par famter le Jeu 23 Aoû - 13:58

Je te remercie pour ta réponse rapide. J'ai effectué les modifications que tu demandes, le boot ce poursuit un peu plus loin, mais finit par boucler sur: "Begin Gfx firmware lord process".



J'ai essayé en désactivant le firmware avec le Flag:-disablegfxfirmware.
Dans cette configuration le PC ce plante.


Ci cela peut-être utile:  ha26
config.plist:

Code:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
   <key>ACPI</key>
   <dict>
      <key>DSDT</key>
      <dict>
         <key>Debug</key>
         <false/>
         <key>DropOEM_DSM</key>
         <false/>
         <key>Fixes</key>
         <dict>
            <key>FixShutdown</key>
            <true/>
         </dict>
         <key>Name</key>
         <string>DSDT.aml</string>
         <key>ReuseFFFF</key>
         <false/>
      </dict>
      <key>DropTables</key>
      <array>
         <dict>
            <key>Signature</key>
            <string>SSDT</string>
            <key>TableId</key>
            <string>Cpu0Ist</string>
         </dict>
         <dict>
            <key>Signature</key>
            <string>SSDT</string>
            <key>TableId</key>
            <string>CpuPm</string>
         </dict>
         <dict>
            <key>Signature</key>
            <string>DMAR</string>
         </dict>
      </array>
      <key>FixHeaders</key>
      <true/>
      <key>FixMCFG</key>
      <true/>
      <key>SSDT</key>
      <dict>
         <key>DropOem</key>
         <false/>
         <key>EnableC6</key>
         <true/>
         <key>EnableC7</key>
         <true/>
         <key>Generate</key>
         <dict>
            <key>APLF</key>
            <true/>
            <key>APSN</key>
            <true/>
            <key>CStates</key>
            <true/>
            <key>PStates</key>
            <true/>
            <key>PluginType</key>
            <true/>
         </dict>
      </dict>
   </dict>
   <key>Boot</key>
   <dict>
      <key>Arguments</key>
      <string>kext-dev-mode=1 rootless=0 shikigva=1 -disablegfxfirmware</string>
      <key>CustomLogo</key>
      <false/>
      <key>DefaultVolume</key>
      <string>MacHDD</string>
      <key>Legacy</key>
      <string>PBR</string>
      <key>Log</key>
      <false/>
      <key>Timeout</key>
      <integer>5</integer>
      <key>XMPDetection</key>
      <false/>
      <key>SkipHibernateTimeout</key>
      <false/>
      <key>StrictHibernate</key>
      <false/>
      <key>RtcHibernateAware</key>
      <false/>
   </dict>
   <key>Devices</key>
   <dict>
      <key>Audio</key>
      <dict>
         <key>Inject</key>
         <string>No</string>
      </dict>
      <key>FakeID</key>
      <dict>
         <key>ATI</key>
         <string>0x0</string>
         <key>IMEI</key>
         <string>0x0</string>
         <key>IntelGFX</key>
         <string>0x59168086</string>
         <key>LAN</key>
         <string>0x0</string>
         <key>NVidia</key>
         <string>0x0</string>
         <key>SATA</key>
         <string>0x0</string>
         <key>WIFI</key>
         <string>0x0</string>
         <key>XHCI</key>
         <string>0x0</string>
      </dict>
      <key>USB</key>
      <dict>
         <key>AddClockID</key>
         <true/>
         <key>FixOwnership</key>
         <true/>
         <key>Inject</key>
         <true/>
      </dict>
   </dict>
   <key>DisableDrivers</key>
   <array>
      <string>Nothing</string>
   </array>
   <key>GUI</key>
   <dict>
      <key>Hide</key>
      <array>
         <string>Windows</string>
         <string>BOOTX64.EFI</string>
         <string>Preboot</string>
      </array>
      <key>Language</key>
      <string>en:0</string>
      <key>Mouse</key>
      <dict>
         <key>Enabled</key>
         <true/>
         <key>Speed</key>
         <integer>8</integer>
      </dict>
      <key>Scan</key>
      <dict>
         <key>Entries</key>
         <true/>
         <key>Legacy</key>
         <true/>
         <key>Tool</key>
         <true/>
      </dict>
      <key>ScreenResolution</key>
      <string>1920x1080</string>
      <key>Theme</key>
      <string>Simplicity</string>
   </dict>
   <key>Graphics</key>
   <dict>
      <key>ig-platform-id</key>
      <string>0x59120000</string>
      <key>Inject</key>
      <dict>
         <key>ATI</key>
         <false/>
         <key>Intel</key>
         <true/>
         <key>NVidia</key>
         <false/>
      </dict>
   </dict>
   <key>KernelAndKextPatches</key>
   <dict>
      <key>AppleIntelCPUPM</key>
      <true/>
      <key>AppleRTC</key>
      <true/>
      <key>Debug</key>
      <false/>
      <key>KernelCpu</key>
      <false/>
      <key>KernelLapic</key>
      <false/>
      <key>KernelPm</key>
      <false/>
      <key>KernelXCPM</key>
      <false/>
      <key>KextsToPatch</key>
      <array>
         <dict>
            <key>Comment</key>
            <string>External icons patch</string>
            <key>Disabled</key>
            <false/>
            <key>Find</key>
            <data>RXh0ZXJuYWw=</data>
            <key>Name</key>
            <string>AppleAHCIPort</string>
            <key>Replace</key>
            <data>SW50ZXJuYWw=</data>
         </dict>
      </array>
   </dict>
   <key>RtVariables</key>
   <dict>
      <key>BooterConfig</key>
      <string>0x28</string>
      <key>CsrActiveConfig</key>
      <string>0x3E7</string>
   </dict>
   <key>SystemParameters</key>
   <dict>
      <key>InjectKexts</key>
      <string>Yes</string>
      <key>InjectSystemID</key>
      <true/>
   </dict>
</dict>
</plist>
famter
famter

Messages : 4
Date d'inscription : 10/08/2018

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème démarrage OSx Mojave 10.14.18

Message par chris1111 le Jeu 23 Aoû - 21:14

Ajoute aux boot args
-disablegfxfirmware

_________________
Faite des Tutos d'installation après avoir réussi votre Hackintosh

Faire un Don pour le Forum
chris1111
chris1111
Admin
Admin

Messages : 24973
Date d'inscription : 18/12/2012
Localisation : Laval. Québec Canada

Voir le profil de l'utilisateur http://hackintosh--montreal.forum-canada.com

Revenir en haut Aller en bas

Re: Problème démarrage OSx Mojave 10.14.18

Message par famter le Ven 24 Aoû - 4:22

Comme dis dans mon dernier message l'option -disablegfxfirmware dans le boot plante mon PC.
Par contre j'ai essayé de remplacer la valeur de "ig-platform-id" par   0x12345678 et cela fonctionne mais uniquement en mode verbose.
C'est déjà pas mal ça va me permettre d'aller plus loin,
Je vais fouiller un peu tout ça pour voir ci-tout mon matériel est fonctionnel.
Very Happy
famter
famter

Messages : 4
Date d'inscription : 10/08/2018

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Problème démarrage OSx Mojave 10.14.18

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum