HACKINTOSH MONTRÉAL & FRANCE

Désactivé le GPU Capt1051
Vous devez lire la charte et vous présenter avant de poster!
➤  La Charte du Forum

➤  Présentation

Rejoignez le forum, c’est rapide et facile

HACKINTOSH MONTRÉAL & FRANCE

Désactivé le GPU Capt1051
Vous devez lire la charte et vous présenter avant de poster!
➤  La Charte du Forum

➤  Présentation
HACKINTOSH MONTRÉAL & FRANCE
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.
Le Deal du moment : -33%
Casque Gaming Kraken X de Razer à prix ...
Voir le deal
39.99 €

Désactivé le GPU

4 participants

Page 1 sur 2 1, 2  Suivant

Aller en bas

Désactivé le GPU Empty Désactivé le GPU

Message par skuuu Dim 31 Jan - 10:07

bonjour,

j'aimerai savoir si c'est possible de désactivé mon GPU lors ce que je tourne sur mon mac.
J'ai un Big sur qui tourne sur mon CPU mais le fait de détaché et de replacer mon GPU à chaque fois pour jouer ou utilisé un logiciels qui utilise les GPU est vraiment chiant.
j'ai déjà essayé d'utiliser cette solution:

"Boot Flag
By far the simplest way, all you need to do is add the following boot-arg:
-wegnoegpu
Do note that this will disable all GPUs excluding the iGPU."

J'ai essayé de plug mon écran sur le GPU (la progression du logo mac s’arrete à1/3) ensuite sur le CPU mais ça n'a pas fonctionné.(je ne sais pas s'il faut changer aussi le "AAPL,ig-platform-id" )

j'ai vu qu'il y a d'autre méthode tel que SSDT patch Method( ou spoof, je ne sais pas si c'est le même) mais j'aimerai être prudent et c'est pour ça que je vous demande de l'aide.

Vous pouvez m'aider s'il vous plait ? ha5
skuuu
skuuu

Date d'inscription : 21/01/2021
Localisation : FRANCE

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par skuuu Jeu 4 Fév - 12:36

Si non on peut m’aider avec la méthode gfxutil/config.plist(devices propreties method ) s’il vous plaît 🙏
skuuu
skuuu

Date d'inscription : 21/01/2021
Localisation : FRANCE

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par enzooz Ven 5 Fév - 12:55

Tu utilise le UHD 630 avec ton i5 8600k?
enzooz
enzooz

Date d'inscription : 29/01/2021

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par skuuu Dim 7 Fév - 15:18

@enzooz a écrit:Tu utilise le UHD 630 avec ton i5 8600k?
Oui c’est ça
skuuu
skuuu

Date d'inscription : 21/01/2021
Localisation : FRANCE

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par demolay Lun 8 Fév - 2:07

fais une recherche pour SSDT-Z370-Disable-GPU.aml ordi

demolay
demolay
Top usr
Top usr

Date d'inscription : 12/12/2016
Localisation : Alpes

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par emax31 Lun 8 Fév - 2:30

Méthode simple
boot args  tu mets -wegnoegpu
ou tu fais un ssdt méthode dortania plus complexe en t'aidant de windows

Pour faire reconnaitre IGPU
dans device properties tu rentres les valeurs pour le UHD 630
Fichiers joints
Désactivé le GPU Attachment
DeviceProperties.plist.zip Vous n'avez pas la permission de télécharger les fichiers joints.(1 Ko) Téléchargé 6 fois

_________________
 Thèmes  :

Icnspack-Builder & source thème by chris1111
Désactivé le GPU Flavou14
Désactivé le GPU 26191810
Désactivé le GPU 28143910
Désactivé le GPU 28113810



Important : Une fois résolu, l'auteur du sujet peut ajouter [Résolu] au début du titre en cliquant sur Editer de son premier message, et ajouter un bref récapitulatif de la solution à la fin de celui-ci ou mieux faire un tuto. Merci.
emax31
emax31
Gourou
Gourou

Date d'inscription : 04/12/2013
Localisation : Ariège - Grenoble - France

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par skuuu Mer 10 Fév - 4:24

et quand que je veux essayé ou quand j'aurai terminer je peux plug mon écran directement sur mon CG et boot mon mac dessus ou est ce que je plug mon écran sur ma CM et lancer mac avec ?
skuuu
skuuu

Date d'inscription : 21/01/2021
Localisation : FRANCE

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par skuuu Mer 10 Fév - 5:14

@demolay a écrit:fais une recherche pour  SSDT-Z370-Disable-GPU.aml ordi


merci pour ta proposition mais je n'ai trouvé qu'une ou deux solution en plus comme j'utilise OpenCore  malheureusement les solutions sont soit pour les clovers où je dois Dump le SSDT soit il y a des fichier téléchargeable mais qui sont plus disponible Sad
skuuu
skuuu

Date d'inscription : 21/01/2021
Localisation : FRANCE

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par skuuu Mer 10 Fév - 5:21

@emax31 a écrit:Méthode simple
boot args  tu mets -wegnoegpu
ou tu fais un ssdt méthode dortania plus complexe en t'aidant de windows

Pour faire reconnaitre IGPU
dans device properties tu rentres les valeurs pour le UHD 630

merci je vais essayé la solution avec le boot args avec les valeurs que tu m'as demandé d'ajouter mais est ce que je peux directement monté ma CG et me boot directement dessus ou est ce que je le monte juste et je boot sur ma CM ?
skuuu
skuuu

Date d'inscription : 21/01/2021
Localisation : FRANCE

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par emax31 Mer 10 Fév - 7:30

@skuuu a écrit:merci je vais essayé la solution avec le boot args avec les valeurs que tu m'as demandé d'ajouter mais est ce que je peux directement monté ma CG et me boot directement dessus ou est ce que je le monte juste et je boot sur ma CM ?

En relisant je n'ai pas compris car Nvidia ça ne marche pas pour Big sur sauf les nvidia kepler.
"J'ai un Big sur qui tourne sur mon CPU mais le fait de détaché et de replacer mon GPU à chaque fois .... "
Il tourne avec quoi ton Big Sur . Quelle carte graphique utilises tu pour cela?

Il te faut essayer, si pas de carte graphique tu élimines les problèmes mais d'un autre coté il faut que ça fonctionne du premier coup car sinon ce ne sera pas commode pour mettre au point la configuration en IGPU.
As tu un ou 2 écrans ?
Si 2 écrans un branché en HDMI sur IGPU et l'autre sur CG et tu joues avec le paramétrage du bios de PEG à IGPU.

_________________
 Thèmes  :

Icnspack-Builder & source thème by chris1111
Désactivé le GPU Flavou14
Désactivé le GPU 26191810
Désactivé le GPU 28143910
Désactivé le GPU 28113810



Important : Une fois résolu, l'auteur du sujet peut ajouter [Résolu] au début du titre en cliquant sur Editer de son premier message, et ajouter un bref récapitulatif de la solution à la fin de celui-ci ou mieux faire un tuto. Merci.
emax31
emax31
Gourou
Gourou

Date d'inscription : 04/12/2013
Localisation : Ariège - Grenoble - France

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par skuuu Mer 10 Fév - 8:41

@emax31 a écrit:
@skuuu a écrit:merci je vais essayé la solution avec le boot args avec les valeurs que tu m'as demandé d'ajouter mais est ce que je peux directement monté ma CG et me boot directement dessus ou est ce que je le monte juste et je boot sur ma CM ?

En relisant je n'ai pas compris car Nvidia ça ne marche pas pour Big sur sauf les nvidia kepler.
"J'ai un Big sur qui tourne sur mon CPU mais le fait de détaché et de replacer mon GPU à chaque fois .... "
Il tourne avec quoi ton Big Sur . Quelle carte graphique utilises tu pour cela?

Il te faut essayer, si pas de carte graphique tu élimines les problèmes mais d'un autre coté il faut que ça fonctionne du premier coup car sinon ce ne sera pas commode pour mettre au point la configuration en IGPU.
As tu un ou 2 écrans ?
Si 2 écrans un branché en HDMI sur IGPU et l'autre sur CG et tu joues avec le paramétrage du bios de PEG à IGPU.

Enfaite quand je joue ou quand j'utilise solidWork (logiciel de création de pièces en 3D ,,,) je vais sur windows en mentant mon RTX 2080 TI en connectant mon écran dessus et quand je veux utilisé MacOs je démente ma CG et je connecte directement mon écran sur ma CM pour utilisé l'UHD 630,

J'ai bien d'autre écran mais je ne l'ai utilise pratiquement pas parcequ'ils sont limité à 60 Hz avec une résolution HD (donc pas très fluide et moin beau par rapport à mon écran principal qui fait du 144 hz avec une résolution WQHD+ ),

Du coup est ce que j'essaie d'utiliser une 2ème écran connecté sur ma CM et mon écran principal connecté sur ma CG?
skuuu
skuuu

Date d'inscription : 21/01/2021
Localisation : FRANCE

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par emax31 Mer 10 Fév - 9:09

Oui essaye avec un 2ieme écran connecté en HDMI tu seras en 1920x1080.
Celui en WQHD+ il doit être connecté en DP
Tu joues sur le bios PEG et IGD .
PEG windows
IGD macos
Mais il te faut quand même désactiver la nvidia soit par le SSDT soit avec  -wegnoegpu.
Il faut que ça fonctionne comme ça car c'est pas concevable  d'avoir à démonter la carte graphique à chaque fois.
Tu l'as réalisé ton SSDT ?
Guide dortania --> google --> "disabled nvidia opencore"

_________________
 Thèmes  :

Icnspack-Builder & source thème by chris1111
Désactivé le GPU Flavou14
Désactivé le GPU 26191810
Désactivé le GPU 28143910
Désactivé le GPU 28113810



Important : Une fois résolu, l'auteur du sujet peut ajouter [Résolu] au début du titre en cliquant sur Editer de son premier message, et ajouter un bref récapitulatif de la solution à la fin de celui-ci ou mieux faire un tuto. Merci.
emax31
emax31
Gourou
Gourou

Date d'inscription : 04/12/2013
Localisation : Ariège - Grenoble - France

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par skuuu Mer 10 Fév - 12:32

Je sais pas si ma méthode est bonne:
j'ai enregistré "Spoof-SSDT" en ".AML" avec MaciASL et j'ai placé dans EFI>OC>ACPI.

j'aimerai juste savoir si ces lignes de commande sont bon:


L'emplacement de ma CG est
"ACPI(_SB_)#ACPI(PCI0)#ACPI(PEG0)#ACPI(PEGP)"
"ACPI(_SB_)#ACPI(USBX)#ACPI(PEG0)#ACPI(PEGP)"
"PCIROOT(0)#PCI(0100)#PCI(0000)"


DefinitionBlock ("", "SSDT", 2, "DRTNIA", "spoof", 0x00000000)
{
   External (_SB_.PCI0.PEG0.PEGP, DeviceObj)

   Method (_SB.PCI0.PEG0.PEGP._DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
   {
       If ((!Arg2 || (_OSI ("Darwin") == Zero)))
       {
           Return (Buffer (One)
           {
                0x03                                             // .
           })
       }

       Return (Package (0x0A)
       {
           "name",
           Buffer (0x09)
           {
               "#display"
           },

           "IOName",
           "#display",
           "class-code",
           Buffer (0x04)
           {
                0xFF, 0xFF, 0xFF, 0xFF                           // ....
           },

           "vendor-id",
           Buffer (0x04)
           {
                0xFF, 0xFF, 0x00, 0x00                           // ....
           },

           "device-id",
           Buffer (0x04)
           {
                0xFF, 0xFF, 0x00, 0x00                           // ....
           }
       })
   }
}
skuuu
skuuu

Date d'inscription : 21/01/2021
Localisation : FRANCE

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par emax31 Jeu 11 Fév - 7:23

@skuuu a écrit:Je sais pas si ma méthode est bonne:
j'ai enregistré "Spoof-SSDT" en ".AML" avec MaciASL et j'ai placé dans EFI>OC>ACPI.

j'aimerai juste savoir si ces lignes de commande sont bon:

L'emplacement de ma CG est
"ACPI(_SB_)#ACPI(PCI0)#ACPI(PEG0)#ACPI(PEGP)"

Oui c'est bon  mais ça aurait du être de la forme
\_SB.PCI0.PEG0.PEGP

Configuration bios
- Multi-moniteur iGPU: activé
- Affichage principal: activé
Les 3 méthodes sont à essayer une à la fois pas les 3 en même temps notamment pour 2 et 3

Méthode1 dans le boot args
-wegnoegpu

Méthode2
DeviceProperties --> Ci joint


Méthode3
Avec le ssdt —> Spoof-SSDT.aml --> ci-joint
à mettre dans ACPI pour opencore et dans ACPI patched pour clover
ATTENTION :  il faut également l'activer dans le config[/color]
Fichiers joints
Désactivé le GPU Attachment
DeviceProperties_Nvidia.plist.zip Vous n'avez pas la permission de télécharger les fichiers joints.(1 Ko) Téléchargé 3 fois
Désactivé le GPU Attachment
Spoof-SSDT.aml.zip Vous n'avez pas la permission de télécharger les fichiers joints.(1 Ko) Téléchargé 3 fois

_________________
 Thèmes  :

Icnspack-Builder & source thème by chris1111
Désactivé le GPU Flavou14
Désactivé le GPU 26191810
Désactivé le GPU 28143910
Désactivé le GPU 28113810



Important : Une fois résolu, l'auteur du sujet peut ajouter [Résolu] au début du titre en cliquant sur Editer de son premier message, et ajouter un bref récapitulatif de la solution à la fin de celui-ci ou mieux faire un tuto. Merci.
emax31
emax31
Gourou
Gourou

Date d'inscription : 04/12/2013
Localisation : Ariège - Grenoble - France

skuuu aime ce message

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par skuuu Jeu 11 Fév - 8:45

OK merci je vais testé ça ensuite je ferai la récap
skuuu
skuuu

Date d'inscription : 21/01/2021
Localisation : FRANCE

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par skuuu Jeu 11 Fév - 14:03

Bon j'ai testé les méthodes séparément et elles fonctionnent toutes mais je ne peux pas utiliser la résolution 1920x1080 je suis limité à 1280x1024,
c'est peut être à cause de mon connecteur (j'utilise du VGA) prk je n'ai pas une prise hdmi sur ma CM mais 2VGA et 1DP et comme j'utilise déjà le DP pour mon écran principal je n'ai pas un autre,
skuuu
skuuu

Date d'inscription : 21/01/2021
Localisation : FRANCE

emax31 aime ce message

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par emax31 Ven 12 Fév - 2:11

@skuuu a écrit:Bon j'ai testé les méthodes séparément et elles fonctionnent toutes mais je ne peux pas utiliser la résolution 1920x1080 je suis limité à 1280x1024,
c'est peut être à cause de mon connecteur (j'utilise du VGA) prk je n'ai pas une prise hdmi sur ma CM mais 2VGA et 1DP et comme j'utilise déjà le DP pour mon écran principal je n'ai pas un autre,

Envoie une photo des prises arrières du PC, je n'ai pas compris ton DP est forcément pris par la NVIDIA donc il doit te rester pour la carte mère un VGA et une DVI et non un deuxième VGA et une DP pour Z370-A-PRO comme sur cette photo.
Tout dépend des sorties du moniteur, et fonction de cela tu as des adaptateurs
Désactivé le GPU 1024_v10

_________________
 Thèmes  :

Icnspack-Builder & source thème by chris1111
Désactivé le GPU Flavou14
Désactivé le GPU 26191810
Désactivé le GPU 28143910
Désactivé le GPU 28113810



Important : Une fois résolu, l'auteur du sujet peut ajouter [Résolu] au début du titre en cliquant sur Editer de son premier message, et ajouter un bref récapitulatif de la solution à la fin de celui-ci ou mieux faire un tuto. Merci.
emax31
emax31
Gourou
Gourou

Date d'inscription : 04/12/2013
Localisation : Ariège - Grenoble - France

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par skuuu Ven 12 Fév - 11:37

Excuse moi si je me suis mal exprimé mais c’est exactement ce que tu dit,
Enfaîte j’avais cru que c’était un VGA au lieu d’un DVI
skuuu
skuuu

Date d'inscription : 21/01/2021
Localisation : FRANCE

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par emax31 Ven 12 Fév - 13:14

Tu n'as  pas rajouté un deuxième écran ?
Le premier écran en DP sur nvidia
Le deuxième écran en (je ne connais pas les sorties vga ou HDMI)
Si HDMI
Désactivé le GPU Displa10

_________________
 Thèmes  :

Icnspack-Builder & source thème by chris1111
Désactivé le GPU Flavou14
Désactivé le GPU 26191810
Désactivé le GPU 28143910
Désactivé le GPU 28113810



Important : Une fois résolu, l'auteur du sujet peut ajouter [Résolu] au début du titre en cliquant sur Editer de son premier message, et ajouter un bref récapitulatif de la solution à la fin de celui-ci ou mieux faire un tuto. Merci.
emax31
emax31
Gourou
Gourou

Date d'inscription : 04/12/2013
Localisation : Ariège - Grenoble - France

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par skuuu Sam 13 Fév - 7:44

Oui c’est ça, mon 1er écran est sur mon DP( connecté à ma CG) et mon 2ème écran directement connecté sur ma CM via le VGA
skuuu
skuuu

Date d'inscription : 21/01/2021
Localisation : FRANCE

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par skuuu Sam 13 Fév - 9:13

Parcontre’il y a un truc que je ne comprends pas,
Comme j’ai un adaptateur DVI vers VGA je me suis dis que je pourrais avoir la résolution 1920x1080 mais ça n’as’fonctionné quand j’ai essayé, au moment du lancement, le chargement de la pomme s’arrête un peut avant le milieu puis ecran noir alors que quand j’utilise seulement le VGA sans adaptateur j’arrive à faire fonctionner mac.

Et sur Windows ça fonctionne parfaitement avec l’adaptateur j’ai du 1920x1080 😑

Ps: comme je préfère utilisé que mon écran principal, j’ai connecté celle-ci sur ma CM et sur ma CG, je crois qu’il n’y pas de différence entre faire ça et utiliser une 2ème écran 🤔
skuuu
skuuu

Date d'inscription : 21/01/2021
Localisation : FRANCE

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par emax31 Sam 13 Fév - 10:29

Je pense qu'il te faut ça : DP vers VGA adaptateur,DisplayPort

Désactivé le GPU Dp_ver10

_________________
 Thèmes  :

Icnspack-Builder & source thème by chris1111
Désactivé le GPU Flavou14
Désactivé le GPU 26191810
Désactivé le GPU 28143910
Désactivé le GPU 28113810



Important : Une fois résolu, l'auteur du sujet peut ajouter [Résolu] au début du titre en cliquant sur Editer de son premier message, et ajouter un bref récapitulatif de la solution à la fin de celui-ci ou mieux faire un tuto. Merci.
emax31
emax31
Gourou
Gourou

Date d'inscription : 04/12/2013
Localisation : Ariège - Grenoble - France

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par emax31 Dim 14 Fév - 2:13

As tu regardé également le paramétrage dans :
Préférences système --> Moniteurs--> Onglet moniteur --> A l'échelle

_________________
 Thèmes  :

Icnspack-Builder & source thème by chris1111
Désactivé le GPU Flavou14
Désactivé le GPU 26191810
Désactivé le GPU 28143910
Désactivé le GPU 28113810



Important : Une fois résolu, l'auteur du sujet peut ajouter [Résolu] au début du titre en cliquant sur Editer de son premier message, et ajouter un bref récapitulatif de la solution à la fin de celui-ci ou mieux faire un tuto. Merci.
emax31
emax31
Gourou
Gourou

Date d'inscription : 04/12/2013
Localisation : Ariège - Grenoble - France

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par skuuu Mar 16 Fév - 6:48

Pour l’adaptateur dp vers vga je ne vais pas acheter juste pour du hackintosh, du moins pour le moment, du coup j’aimerais juste utiliser mon écran principal en connectant mon DVI et mon DP dur un seul écran( le DP pour ma CG et DVI pour ma CM).
Je ne sais si c’est normal mais je n’arrive pas à lancer mac avec mon DVI, lors du chargement de la pomme la barre s’arrête ~au milieu et ensuite écran noir.
Pour tester son fonctionnement j’ai lancé Windows avec le DVI et ça fonctionne très bien du coup le problème du connecteur ne vien de lui.( je pouvais lancer en 1920x1080)

Et pour "As tu regardé également le paramétrage dans :
Préférences système --> Moniteurs--> Onglet moniteur --> A l'échelle”
Oui j’ai regardé mais je ne pouvais pas aller sur du 1920x1080 avec le vga.
skuuu
skuuu

Date d'inscription : 21/01/2021
Localisation : FRANCE

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par emax31 Mar 16 Fév - 7:12

@skuuu a écrit:
Préférences système --> Moniteurs--> Onglet moniteur --> A l'échelle”
Oui j’ai regardé mais je ne pouvais pas aller sur du 1920x1080 avec le vga.
Fais nous deux copies écran en DP et en VGA des résolutions possibles sous mac ---> A l'échelle ---> onglet moniteur

_________________
 Thèmes  :

Icnspack-Builder & source thème by chris1111
Désactivé le GPU Flavou14
Désactivé le GPU 26191810
Désactivé le GPU 28143910
Désactivé le GPU 28113810



Important : Une fois résolu, l'auteur du sujet peut ajouter [Résolu] au début du titre en cliquant sur Editer de son premier message, et ajouter un bref récapitulatif de la solution à la fin de celui-ci ou mieux faire un tuto. Merci.
emax31
emax31
Gourou
Gourou

Date d'inscription : 04/12/2013
Localisation : Ariège - Grenoble - France

Revenir en haut Aller en bas

Désactivé le GPU Empty Re: Désactivé le GPU

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 1 sur 2 1, 2  Suivant

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum