HACKINTOSH MONTRÉAL & FRANCE


[size=12] Vous devez lire la charte et vous présenter avant de poster!
  La Charte du Forum  [size=12]
[size=12]  Présentation  [size=12]

[En cours] Quels kexts choisir pour ma config ? Son HDMI [ajustable], WiFi , reboot

Aller en bas

[En cours] Quels kexts choisir pour ma config ? Son HDMI [ajustable], WiFi , reboot

Message par IridiumFr le Sam 18 Nov - 14:37

Bonjour,

J'installe un Hackintosh sur le PC ASUS Z87i-PRO en signature.

1) Trouver les réglages de l'UEFI
Chris me communique des copies d'écran
MERCI

2) Faire une clé d'installation de HS

3) Trouver la configuration de Clover pou booter sur la clé
Le Tuto sur Clover 2.4 special edition
me permet de rendre bootable ma clé.

4) Installer High Sierra
Rendu à l'installeur HS, j'échoue à formater mon SSD.

Chris me conseille d'essayer avec GParted.
  Depuis iMac, je télécharge l'image GParted, j'en fais une clé bootable avec UNetBootIn.
  Je supprime toutes les partitions, puis reformate en HFS+

Re Boot Clover. L'Installeur échoue toujours à reformater.

  Retour à l'iMac. Je monte en externe sur un dock le SSD, je lance une session Ubuntu sur VMware, et je formate en FAT.
  Je repasse en OSX, et je reformate en FAT, puis en HSF+J GUID, et là ça marche.

Retour sur le PC, l'installeur HS formate sans problème, mais était-ce bien utile ?
HS s'installe
  Reboot
  Suite de l'installation
  Reboot
Paramétrage du premier lancement...

Pas d'internet, pas de son, mais pas encore de post installation non plus.

4) Post installation.
 Terminal gatekeeper désactivé
 Reboot sur Recovery SIP désactivé
Clover
 Je le trouve avec la même boite de dialogue que lors de la "bootabilisation" de la clé
 Je prends donc les mêmes items, ceux que Chris conseille dans la vidéo citée plus haut.

Reboot, sans la clé

Ça marche. J'ai un PC  qui boote sous OsX High Sierra. Wink
Lorsque le Bootloader se charge, plusieurs volumes sont en double pour le démarrage,
une version avec la mention FileVault, et une sans... kesako ?

Un PC qui n'a toujours pas l'internet, ni le son.

Retour sur le forum
Essai de trouver un post installeur
Je trouve celui-là : Post-installer HMF Clover
Et je ne sais pas quoi cocher, qui correponde à mon matériel...
Je tente :
Clover V2.4 r4289 > BootUEFI   c'est une régression par rapport à la dernière version de l'Edition Spéciale
Driver kext > Network Clover>Intel GB Ethernet + Atheros Killer E2200  je ne sais pas ce que je fais, mais les noms corrspondent...
  Audio > Audio-VoodooHDA 2.8.9

Reboot

Là j'ai intenet en RJ45, pas de WiFi, Atheros n'était pas le bon ?

Toujours pas de son. Tiens, si en essayant au casque sur la prise verte derrière, le son marche...  Very Happy
Pas sur la prise casque devant,
Et pas en HDMI, qui est mon canal ordinaire d'écoute Sad

Comme le son HDMI est géré par la carte Video, je me dis qu'il faut les drivers NVidia.
WebDriver ou CUDA ?

Voilà, j'en suis là, ça a bien avancé.  tu

Restera à remettre un W10 sur un disque dédié, et faire un multiboot,
Vérifier s'il s'endort et se réveille correctement, s'il s'éteint sans redémarrer aussiôt
Si je me suis planté quelque part, je suis bien sûr prêt à tout recommencer, autant de fois que nécessaire jusqu'à ce que la config soit fonctionnelle et stable.

Merci de vos conseils.

————=__=————

Mise à jour le 20 nov à 3:34 heure de Paris:

Le son HDMI fonctionne avec voodoo !
Peut-on rendre le volume réglable ?

Je n'ai pas encore testé tous les ports USB3
Toujours pas de WiFi, comment injecter le correctif qui va bien

Au Boot Clover, il y a 4 volumes qui sont toujours proposés au choix, alors que je n'en attends que 2
• Boot FileVault Prebooter from Preboot : sélectionné le boot se poursuit sur le DD
•• Boot MacOs Install Prebooter from Preboot : sélectionné, il arrête le boot (sens interdit)
••• Boot MacOs from SSD240 : le boot "normal selon moi
•••• BootBoot Recovery from Recovery : la partition de ssauvegarde Apple

Qu'est ce que ça signifie, comment enlever ces 2 fantômes ?

À l'extinction, il reboote, chaque fois.
Comment régler ça ?

————=__=————

Mise à jour 23 novemrbe

• J'ai renoncé au HFS+ sur mon SSD, je n'ai pas de raison valable de ne pas accompagner l'évolution.
•• Du coup j'ai posé avec Clover Configurator l'exclusion des volumes "preboot", c'est propre au démarrage.

••• Le correctif pour ma WiFi  ATH9KFixup.kext n'a pas apporté de solution. Je n'ai toujours pas de WIFI.
Peut-être la solution viendra par l'acquisition d'une carte compatible dédiée.
Si oui laquelle conseilleriez-vous ?

•••• L'extinction est toujours suivie d'un reboot…

Les ports USB3 fonctionnent, mais pas au Boot, si bien que je ne peux pas utiliser les prises USB en façade pour insérer la clé Clover. C'est vraiment la moindre des choses !

————=__=————

Mise à jour 25 novembre

Après quelques recherches sur les différents forums, je n'ai pas trouvé de cas où quelqu'un ait réussi à faire fonctionner une Atheros AR9462.
RehabMan affirme même qu'elle est définitivement incompatible… bien que ath9k sur linux fonctionne tout-à-fait semble-t'il. Mad

Or ma CM est au format mini, 1 seul port PCIe3.0 pour la carte graphique, et le module WiFi GO + BT soudé sur la carte mère.
Je ne peux pas mettre une carte compatible.
Question Ça marche avec une clé USB WiFi et une BT ?

Auriez-vous un conseil SVP ?


Dernière édition par IridiumFr le Lun 20 Nov - 8:15, édité 1 fois
avatar
IridiumFr

Messages : 34
Date d'inscription : 30/04/2013
Age : 59
Localisation : Centre France

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum