HACKINTOSH MONTRÉAL & FRANCE


Vous êtes invités a lire la charte du Forum  ICI avant de poster! La Charte du Forum


Install OSX sur Gigabyte GA-X79-UP4 f5 ou f7, NVIDIA GTX 760

Voir le sujet précédent Voir le sujet suivant Aller en bas

Install OSX sur Gigabyte GA-X79-UP4 f5 ou f7, NVIDIA GTX 760

Message par snopub le Lun 21 Avr 2014 - 10:33

Bonjour  tout le monde.

Comme je ne m'y connais pas beaucoup en hackintosh et que j'ai un peu galéré, je vous décris (à défaut de savoir expliquer) les paramètres qui m'ont permis d'avoir un OSX 10.9.2 fonctionnel sur ma config GA-X79-up4 f7 (f5 au moment de l'install), GTX760.

En espérant que cela pourra servir à d'autres.
Merci encore à tous ceux qui m'ont aidé dans ce processus.

On commence par le BIOS :

1. Onglet Save&Exit : sélectionner "Load Optimized Defaults", Entrée, 'Yes', Entrée

2. Onglet MIT :

    a. "Advanced CPU Core Settings", "CPU EIST Function", 'Disabled'

    b. "Extreme Memory Profile(XMP), "Profile 1"

3. Onglet Bios Features :

    a. "Hard Drive BBS Priorities",

         - "Boot Option #1", choisir le disque à partir duquel vous souhaitez démarrer (d'abord la clé USB pour faire l'install puis ensuite le disque sur lequel OS X est installé)

         - "Boot Option #2", dans mon cas le disque sur lequel Windows est installé.

         - "Boot Option #3", dans mon cas 'Disabled' pour ne pas voir apparaître mon disque de données lors du démarrage

    b. "Boot Option Priorities",

         - "Boot Option #1", choisir le disque non UEFI à partir duquel vous souhaitez démarrer (d'abord la clé USB pour faire l'install puis ensuite le disque sur lequel OS X est installé)

         - "Boot Option #2", dans mon cas 'Disabled'
         - "Boot Option #3", dans mon cas 'Disabled'

    c. "Full Screen LOGO Show", 'Disabled', pour voir ce qu'il se passe pendant le hardboot

    d. "Fast Boot", 'Disabled' (normalement par défaut)

    e. "Intel(R) VT-d", 'Disabled' (normalement par défaut)

    f. "Windows 8", 'Other OS' (normalement par défaut)

    g. "Boot Mode Selection", 'UEFI and Legacy' (normalement par défaut)

    h. "Storage Boot Option Control", 'Legacy First' (normalement par défaut)

    i. "Network Stack", 'Disabled' (normalement par défaut)


4. Onglet Peripherals

    a. "Initial Display Output", dans mon cas 'PCIe 3 Slot' car Monsieur est trop bête et a pris un ventirad trop grand 14cm... Wink

Ceci dit, ils ont été radins chez Gigabyte au niveau écartement "CPU/PCIe Slot 1" donc je le précise quand même pour ceux qui voudraient un gros ventirad CPU. Que ma bétise serve à qqn au moins !

    b. "High Precision Timer", 'Enabled' (normalement par défaut)

    c. "XHCI Hand-off" et "EHCI Hand-off", 'Enabled'

    d. "SATA Configuration"

         - "SATA Mode", 'AHCI Mode'
         - "Port n Hot Plug", dans mon cas :
             'Disabled' sur les ports où se trouvent mes disques de systèmes (OSX, Win7).
             'Enabled' sur les autres ports

Remarque : cela me permet de ne pas voir apparaitre sur le bureau OSX le disque Windows et sur le bureau Windows de ne pas avoir mon disque système retirable à chaud dans la barre des tâches.

    e. "Super IO Configuration", 'Disabled' dans mon cas car je ne m'en sers pas

    f. "Marvell SATA Controller Configuration", 'Disabled' dans mon cas car je ne m'en sers pas sinon 'AHCI mode'

    g. "Intel(R) 82579LM Giga...", "NIC Configuration", "Link Speed", 'AutoNeg'.

Remarque : pour une raison que j'ignore, les autres valeurs ne proposent pas le 1000Mbps...

    h. "Wake on LAN", 'Disabled' pour l'instant car je n'ai pas bcp de retour dessus (pb de conflit j'ai cru lire...)

5. Onglet Power Management, "Wake on Lan from S5", 'Disabled' aussi pour l'instant.

6. Onglet Save&Exit

    a. "Save Profiles", ça ne coûte rien de faire une sauvegarde de son paramétrage.

Dans mon cas je me suis fait un profil MAC (celui que je viens de décrire plus haut) et un profil PC avec certains paramètres en plus 'Enabled'. Mais dans la pratique je reste assez souvent sur le profil 'MAC' même quand je suis en mode PC...
Attention tout de même lors d'une mise à jour BIOS, les profils sont effacés.

    b. SAVE & EXIT SETUP !!!


Pour l'installation de l'OSX
Cela est finalement devenu très simple grâce à ce forum.

Pour info j'ai essayé de bien des façons d'installer à partir du CD Original un MAC OS X 10.6.3 (Snow Leopard).
J'y suis arrivé mais ma config matérielle étant assez récente, presqu' aucune fonctionnalité propre à cette dernière (CPU, RAM) n'était reconnue Sad


Naturellement j'ai voulu mettre à jour vers 10.8 et 10.9 et donc faire des clés/disques de boot 10.8 ou 10.9.
A chaque fois qqch bloquait... des kexts manquants ou pas adaptés, des kernel panic, des écrans noirs... d'une noirceur infini... mais parfois sans message d'erreur !


Néanmoins il ne faut pas désespérer car j'ai trouvé ici la seule méthode qui m'ait permis d'aller au bout sans aucune erreur.

Tout d'abord dans la section VIDEO :

- la méthode de MoonlightAngell pour installer un VM avec OSX 10.8.
Remarque : Le lien vers la vidéo n'est plus le bon  mais le lien (un peu au-dessus) vers le post est valide et pointe vers les bonnes vidéos.

- puis les videos de chris1111 sur son outil 'Installer V10'.

Ces deux méthodes vraiment très claires m'ont permis d'avancer.

Le fichier boot.plist
Je vous décris ci-dessous les paramètres utilisés pour ma config, cochés sur Chameleon Wizard dans l'onglet org.chameleon.Boot.plist :

1. Rubrique Boot Flags

- Verbose mode (-v) : décochée maintenant mais cochée pendant tout le processus d'installation pour pouvoir visualiser le processus de démarrage.
- Ignore Boot cache (-f)
- GUI
- Time Out : 3 dans mon cas, je suis pressé Wink
- Kernel : cochée, valeur mach_kernel. J'utilise celui de nawcom dispo sur le forum.
       Pour l'installer :
         - Renommer le fichier téléchargé en mach_kernel.new
         - Copier le à la racine du disque système
         - Redémarrer en mode Single User (option bootflag -s).
         - Une fois sur le prompt, taper ces commandes :
         fsck -fy
         mount -uw /
         cp /mach_kernel /mach_kernel.old (Cela fait un backup du fichier nommé .old)
         cp /mach_kernel.new /mach_kernel (Ecrase le fichier actuel par le nouveau)
         chown root:wheel /mach_kernel
         chmod 644 /mach_kernel (répare les permissions)

2. Rubrique Miscellaneous

- Use Kernel Cache
- npci=0x2000 (indispensable avec ma config)
- darkwake=0
- Ethernet Built In
- Restart Fix

3. Rubrique Graphics

- Skip Intel GFX (pas de GPU Intel dans mon cas)
- Skip AMD (ATI) GFX (idem)
- Graphics Mode cochée, valeur 1920x1080x32 (dans mon cas mais à adapter en fonction de votre résolution)
- PCIRoot=1

Tout le reste est décoché mais comme je n'y connais pas grand chose et que cela fonctionne, je n'ai pas tenté d'aller plus loin.
D'ailleurs si qqn a des conseils à me donner pour optimiser, je suis preneur !

Enfin pour compléter la description de ma config, j'ai utilisé le smbios iMac14.2 et le fichier ssdt.aml proposé par rampagedev.wordpress.com mais juste le fichier sans utiliser sa procédure.
J'avoue que je ne comprends pas bien encore comment cela fonctionne... donc en attendant d'en savoir plus j'en suis resté là.

Voilà j'espère que cela permettra à d'autres possesseurs de x79-up4 de se faire plaisir.

Et puis si comme moi, vous pensez que ce forum c'est le meilleur, n'hésitez pas à contribuer et à donner quelques pépètes d'autant plus que vous avez économisé sur l'achat d'un MAC Wink

SNO (débutant aussi bien en hackintosh qu'en forum donc merci pour vos remarques et votre indulgence).


Dernière édition par snopub le Mar 22 Avr 2014 - 6:16, édité 8 fois (Raison : Correction d'accents (copie PC-MAC) et mise en forme)

_________________
OS X 10.9.2
GA-X79-UP4 bios f5
i7 4820k
16 Go RAM
N760 TF 2GD5/OC
SSD Samsung Evo 840 120Go
HD 1To

snopub

Messages : 15
Date d'inscription : 11/04/2014
Age : 44
Localisation : Val de Marne (94) FRANCE

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

L'auteur de ce message est actuellement banni du forum - Voir le message

Re: Install OSX sur Gigabyte GA-X79-UP4 f5 ou f7, NVIDIA GTX 760

Message par snopub le Mar 22 Avr 2014 - 6:19

Le post a été corrigé.
Merci Alex pour tes remarques.
SNO

_________________
OS X 10.9.2
GA-X79-UP4 bios f5
i7 4820k
16 Go RAM
N760 TF 2GD5/OC
SSD Samsung Evo 840 120Go
HD 1To

snopub

Messages : 15
Date d'inscription : 11/04/2014
Age : 44
Localisation : Val de Marne (94) FRANCE

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

L'auteur de ce message est actuellement banni du forum - Voir le message

Re: Install OSX sur Gigabyte GA-X79-UP4 f5 ou f7, NVIDIA GTX 760

Message par chris1111 le Mar 22 Avr 2014 - 9:36

Super  Very Happy cheers Merci snopub pour ce tutorial  aprouve  ceal vas servir de guide pour les utilisateur de GA X79  16312 bravo 

chris1111
Admin
Admin

Messages : 18187
Date d'inscription : 18/12/2012
Localisation : Montreal (Quebec)

Voir le profil de l'utilisateur http://www.hackintosh-montreal.com

Revenir en haut Aller en bas

Re: Install OSX sur Gigabyte GA-X79-UP4 f5 ou f7, NVIDIA GTX 760

Message par cabanon09 le Ven 25 Avr 2014 - 15:02

Merci pour la communauté...
 tu 

_________________

Signature:

cabanon09
Genie
Genie

Messages : 2181
Date d'inscription : 04/06/2013
Age : 54
Localisation : Ariège France

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Install OSX sur Gigabyte GA-X79-UP4 f5 ou f7, NVIDIA GTX 760

Message par mrfrost le Dim 9 Nov 2014 - 13:35

j'aimerais en savoir un peux plus sur ta memoire ram. Quelle marque ?

_________________
Config: i7 4820k Ga-X79-UP4 32gb Ram EVGA GTX 760 128gb SSD ADATA

mrfrost
Top usr
Top usr

Messages : 51
Date d'inscription : 03/05/2014
Localisation : Montreal

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Install OSX sur Gigabyte GA-X79-UP4 f5 ou f7, NVIDIA GTX 760

Message par Invité le Sam 13 Déc 2014 - 7:04

Bonjour,
b. "Boot Option Priorities", - "Boot Option #1", choisir le disque non UEFI à partir duquel vous souhaitez démarrer (d'abord la clé USB pour faire l'install puis ensuite le disque sur lequel OS X est installé) a écrit:
Ton installation sur tà clé tu l'a fais en UEFI ou en Legacy?

Invité
Invité


Revenir en haut Aller en bas

Re: Install OSX sur Gigabyte GA-X79-UP4 f5 ou f7, NVIDIA GTX 760

Message par Contenu sponsorisé Aujourd'hui à 14:19


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum